2.3.1.5 Packet Tracer - Configuring PVST+
Part 1: Configure VLANs
Part 2: Configure Spanning Tree PVST+ and Load Balancing
Part 3: Configure PortFast and BPDU Guard
Step 1: Enable the user ports on S1, S2, and S3 in access mode.
Refer to the topology diagram to determine which switch ports (S1, S2, and S3) are activated for end-user device access. These three ports will be configured for access mode and enabled with the no shutdown command.
S1>ena
S1#configure
terminal
Enter
configuration commands, one per line. End with CNTL/Z.
S1(config)#interface
fastEthernet 0/6
S1(config-if)#switchport
mode access
S1(config-if)#switchport
access vlan 30
%
Access VLAN does not exist. Creating vlan 30
S1(config-if)#no shutdown
S2>ena
S2#configure
terminal
Enter
configuration commands, one per line. End with CNTL/Z.
S2(config)#interface fastEthernet 0/18
S2(config-if)#switchport mode access
S2(config-if)#switchport access vlan 20
% Access VLAN does not exist. Creating
vlan 20
S2(config-if)#no shutdown
S3>ena
S3#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
S3(config)#interface fastEthernet 0/11
S3(config-if)#switchport mode access
S3(config-if)#switchport access vlan 10
% Access VLAN does not exist. Creating vlan 10
S3(config-if)#no shutdown
Step 2: Create VLANs.
Using the appropriate command, create VLANs 10, 20, 30, 40, 50, 60, 70, 80, and 99 on all of the switches.
S3>ena
S3#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
S3(config)#interface fastEthernet 0/11
S3(config-if)#switchport mode access
S3(config-if)#switchport access vlan 10
% Access VLAN does not exist. Creating vlan 10
S3(config-if)#no shutdown
Step 2: Create VLANs.
Using the appropriate command, create VLANs 10, 20, 30, 40, 50, 60, 70, 80, and 99 on all of the switches.
S1(config)#vlan 10
S1(config-vlan)#vlan 20
S1(config-vlan)#vlan 30
S1(config-vlan)#vlan 40
S1(config-vlan)#vlan 50
S1(config-vlan)#vlan 60
S1(config-vlan)#vlan 70
S1(config-vlan)#vlan 80
S1(config-vlan)#vlan 99
S1(config-vlan)#
(lakukan hal yang sama di switch S2 dan S3)
Step 3: Assign VLANs to switch ports.
Port assignments are listed in the table at the beginning of the activity. Save your configurations after assigning switch ports to the VLANs.
Port assignments are listed in the table at the beginning of the activity. Save your configurations after assigning switch ports to the VLANs.
Step 4: Verify the VLANs.
Use the show vlan brief command on all switches to verify that all VLANs are registered in the VLAN table.
Use the show vlan brief command on all switches to verify that all VLANs are registered in the VLAN table.
S1#show vlan brief
Step 5: Assign the trunks to native VLAN 99.
Use the appropriate command to configure ports F0/1 to F0/4 on each switch as trunk ports, and assign these trunk ports to native VLAN 99.
Configure the management interface on all three switches with an address.Verify that the switches are correctly configured by pinging between them.
Use the appropriate command to configure ports F0/1 to F0/4 on each switch as trunk ports, and assign these trunk ports to native VLAN 99.
Configure the management interface on all three switches with an address.Verify that the switches are correctly configured by pinging between them.
S1#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
S1(config)#interface range fa0/1-4
S1(config-if-range)#switchport mode trunk
S1(config-if-range)#switchport trunk native vlan 99
S1(config-if-range)#exit
S1(config)#interface vlan 99
S1(config-if)#ip address 172.31.99.1 255.255.255.0
S1(config-if)#end
S2#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
S2(config)#interface range fa0/1-4
S2(config-if-range)#switchport mode trunk
S2(config-if-range)#exit
S2(config)#interface vlan 99
S2(config-if)#ip address 172.31.99.2 255.255.255.0
S2(config-if)#end
S3#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
S3(config)#interface range fa0/1-4
S3(config-if-range)#switchport mode trunk
S3(config-if-range)#exit
S3(config)#interface vlan 99
S3(config-if)#ip address 172.31.99.3 255.255.255.0
S3(config-if)#end
Part 2: Configure Spanning Tree PVST+ and Load Balancing
Step 1: Configure STP mode.
Use the spanning-tree mode command to configure the switches so they use PVST as the STP
Use the spanning-tree mode command to configure the switches so they use PVST as the STP
mode.
S1#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
S1(config)#spanning-tree mode pvst
S1(config)#
S2#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
S2(config)#spanning-tree mode pvst
S2(config)#
S3#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
S3(config)#spanning-tree mode pvst
S3(config)#
Step 2: Configure Spanning Tree PVST+ load balancing.
a. Configure S1 to be the primary root for VLANs 1, 10, 30, 50, and 70. Configure S3 to be the primary root for VLANs 20, 40, 60, 80, and 99. Configure S2 to be the secondary root for all VLANs.
S1(config)#spanning-tree vlan 10,30,50,70 root primary
S2(config)#spanning-tree vlan 1,10,20,30,40,50,60,70,80,99 root secondary
S3(config)#spanning-tree vlan 20,40,60,80 root primary
b. Verify your configurations using the show spanning-tree command.
S1(config)#do show spanning-tree
S2(config)#do show spanning-tree
S3(config)#do show spanning-tree
Part 3: Configure PortFast and BPDU Guard
Step 1: Configure PortFast on the switches.
PortFast causes a port to enter the forwarding state almost immediately by dramatically decreasing the time of the listening and learning states. PortFast minimizes the time it takes for the server or workstation to come online. Configure PortFast on the switch interfaces that are connected to PCs.
PortFast causes a port to enter the forwarding state almost immediately by dramatically decreasing the time of the listening and learning states. PortFast minimizes the time it takes for the server or workstation to come online. Configure PortFast on the switch interfaces that are connected to PCs.
S1(config)#int fa0/6
S1(config-if)#spanning-tree portfast
S1(config-if)#exit
S2(config)#int fa0/18
S2(config-if)#spanning-tree portfast
S2(config-if)#exit
S3(config)#int fa0/11
S3(config-if)#spanning-tree portfast
S3(config-if)#exit
Step 2: Configure BPDU guard on the switches.The STP PortFast BPDU guard enhancement allows network designers to enforce the STP domain borders and keep the active topology predictable. The devices behind the ports that have STP PortFast enabled are unable to influence the STP topology. At the reception of BPDUs, the BPDU guard operation disables the port that has PortFast configured. The BPDU guard transitions the port into the err-disable state, and a message appears on the console. Configure BPDU guard on switch interfaces that are connected to PCs.
S1(config)#int fa0/6
S1(config-if)#spanning-tree bpduguard enable
S1(config-if)#
S2(config)#int fa0/18
S2(config-if)#spanning-tree bpduguard enable
S2(config-if)#
S3(config)#int fa0/11
S3(config-if)#spanning-tree bpduguard enable
S3(config-if)#
Step 3: Verify your configuration.
Use the show running-configuration command to verify your configuration.
Use the show running-configuration command to verify your configuration.
Terima kasih sudah membaca. Salam, Soni Setiawan
This comment has been removed by the author.
ReplyDeleteThis comment has been removed by the author.
ReplyDelete